Australian RC Forums banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
2,880 Posts
Discussion Starter · #1 ·
Guys,


I was out with the Savage today and was getting frustrated that it continues to hit and exceed 300F. You will see in another post that I have just sealed the engine, so this was disappointing.


I set the needles to factory, retuned (very slightly) and still hit 300F... this sucks.


Anyway, to cut to the chase, I grabbed my IR Temp Gun (haven't used it since I got the Venom), and hey presto - 30-40F less than the Venom. Hottest it got was 270F - that's cool (pardon the pun).


Has anyone else experienced such huge variations from their Venom Guages? My money is on the IR Temp Gun (it was 6 times the price, but not nearly as convenient), but the Venom is very well regarded.


Could it be a tired battery in the VTM?


Comments would be appreciated.


Thanks,


AUSRC
 

·
Registered
Joined
·
761 Posts
Well, the batteries could be the problem but usually a battery for these type of monitors is surposed to last at least 50, 000 hours... now im not sure on that but its in the thousands at least. also, the battery shouldnt affect it since its only showing numbers on a small screen it isnt moving anything so id say itd work then not work and you would know to change the batt


also, id check:

1. Wires, and the probe, on the venom... check for cuts bent wires things like that

2. placement of probe.. 90 degrees from exhaust port so if looking at the exhaust port on the engine, the probe goes on the left or right side of it

3. Faulty unit... lets hope not

well it could just be that the temp gun is more $$$, but the venom units are highly regarded as being high quality but ive never used one before, although my mip unit seems to work perfectly




Give venom/place of purchase a call or email and let them know they may repair/replace it for you
 

·
Registered
Joined
·
761 Posts
i just thought of something,


is there a good amount of smoke even at the top end? if there is, it would more than likely mean it is going to be running rather cool since my s-25 engine runs at about 150 - 200 (not likely), yes it needs a good tune but ill get to that when my order from tower arrives in a few days


anyway, seems something is wrong with that venom unit you have, as long as the infra red gun is saying 270 tops stick with that since it seems more accurate


let me know how you get it sorted and what happens
 

·
Premium Member
Joined
·
4,136 Posts
I've never had anything to compare my Venom against, but as I have a Duratrax infra red on order from Tower (should get it this week), I'll have something to check it's readings against. http://www.towerhobbies.com/products/duratrax/dtxp3100.html


But of course, that would only open up some more debate if readings were different - which one would be correct!! - It doesn't necessarily follow that more reliable readings come with more dollars invested in the purchase, or does it.........hmmmmmmm...time to start pondering!!


Cheers,





Steve
 
1 - 4 of 4 Posts
Top