Australian RC Forums banner

1 - 18 of 18 Posts
G

·
Discussion Starter · #1 ·
was using the car yesturday....got it all ready, ahd spent a few hours
adjusting cleaning, blah blah fitting on new PVC on rims...etc etc



jump the back fence into the small carpark there...its quite rough but wider than on the road....

was driving along, car stop


i tried everything to get it working....stupid me forgot to recharge the batts in the TX...LOL




anyone else had stupid mistake's like this?



Nismo
 

·
Registered
Joined
·
761 Posts
Hmm..


Ive stood there for about 15 minutes trying to start my savage once, and then noticed there was no shiney blue aluminimum staring up at me.. and then i realised my glow ignitor was still in my pocket
.
 

·
Registered
Joined
·
472 Posts
haha u did that again at the parklands day nick
lol well so did i...also had a run away with nicks glow ignitor attached
umm...did i mention ripping the enging mount flaps off of the s25?


i win
!
 
G

·
Discussion Starter · #4 ·
ahhaaha whoops.....

nothen worse than just resoldered all the wireing then plug in the
batt, take car outside...pull trigger and damn car goes
backwards...arghhhh...



Nismo
 

·
Registered
Joined
·
761 Posts
JoNo-vs-SAVAGE said:
haha u did that again at the parklands day nick
lol well so did i...also had a run away with nicks glow ignitor attached
umm...did i mention ripping the enging mount flaps off of the s25?


i win
!

It wassnt too bad with my glow ignitor on your engine even with your consistent runaways.. for gods sake man TURN ON YOUR RADIO FIRST.


Ahem.. i was a little worried whenyour truck flipped with no body on and landed upside down WITH MY GLOW IGNITOR ATTACHED
.Edited by: Star Guitar
 
G

·
Discussion Starter · #6 ·
WITH MY GLOW IGNITOR ATTACHED
.


LOL funny



man always turn on your radio..lol..i like my esc cause i plug in batt
with TX off, and all it does is turns wheels to one side..



then i go outside..put car down, and turn on TX and off i go



Nismo
 

·
Registered
Joined
·
761 Posts
Peice of advice.. DONT trust Jono with your own equipment on his truck itll get damaged or destroyed within a few minutes
 

·
Registered
Joined
·
472 Posts
haha excuse me..who was running ova buggys with my savage, and i supect the 2 teeth missing on my pinion are from you
lol ohh well its all fun...and the only thing of urs i came close to even harming was ur glow ignitor and well yeah it aint broke so ner
 

·
Registered
Joined
·
761 Posts
LOL. That whole "so ner" ahahaha. Sounds like a little kid
.


Also just cause i was running over rex-x's doesnt mean i blew up your pinion, and anyway, that happens when you do dowies all the time... which is what your fasinated in doing.
 

·
Registered
Joined
·
439 Posts
Close the other day, and i think it might explain why my car was running slow and also the chugging under lock when on throttle, my car just stopped working! The voltage gauge on the Tx was indicating 0 power, so I changed over to brand new batteries and still nothing!


Ended out it was a bit of green crud build up from the battery on one of the battery terminals inside the Tx, scraped it off with my finger nail and got max power from it!! Phew!!


Though would have been a good excuse to upgrade to a nice new wheel radio...
 
G

·
Discussion Starter · #11 ·
lol

nearly then..id never go back to a stick TX...the wheel is so much easier for me use then a stick



Nismo
 

·
Premium Member
Joined
·
2,880 Posts
I once started my .15CV-RX while out of the chassis. It was in a Terra Crusher and I had modded it to utilised the electric start. I wanted to turn it over, and in a moment of weakness forgot that when I powered the starter, I also powered the plug. I had enough fuel in the line to run it for about 20 seconds.


Point 1 - do you have any idea how long 20 seconds feels when you have an engine screaming at full revs, free wheeling out of a chassis.


Point 2 - do you know how loud it is, without the pipe - just the manifold, inside a house at 10.30pm at night.


Point 3 - do you know how hot the exhaust gases are the exit of the manifold when you put your finger over the end to try and shut it down.


I wore a perfectly round blister on poor old pointer for 10 days after....


Regards,


Chris
 

·
Registered
Joined
·
761 Posts
Ahahahahaha Chris, thats funny.


Ive started my .25 a few times outta the savage, but its kinda loud and a little worrying to see it bouncing around the floor lol.


Umm, why were you starting your engine without the exhaust pipe on, at 10:30 at night? Of course its going to be loud, and its gonna annoy people but what would motivate you to do that?


OTHER than the fact itd be cool to see and hear
.
 
G

·
Discussion Starter · #14 ·
i agree SG, but hey ausrc, loud aint it,

when i had the nitro touring car, i got the tuned pipe for it, took that off to see how loud, man it was loud...



even when the engine is off, and you pull the pullstart so the piston goes up then down, it makes a very loud "THUD"



Nismo
 

·
Registered
Joined
·
783 Posts
<TABLE cellSpacing=0 cellPadding=0 width="100%">
<T>
<TR>
<TD class=post vAlign=top>ok you guys had any "brain fart" RC moments.

i put my savvy together with no dogbones....got finished and thought what the hell...why do i have 6 dogbones on my bench still. looked under the truck and just screamed(a word im not aloud to say here)stupid thing is i did it twice
</TD></TR>
<TR>
<TD class=genmed vAlign=bottom height=40>
</TD></TR></T></TABLE>
 

·
Registered
Joined
·
403 Posts
I always forget the e-clip when working on the tranny, put it all back together then there is one thing left in the container. Lets just say Im glad this aint my house.
 

·
Registered
Joined
·
2,114 Posts
lol i was out running with reactor here and i was standing on top of a mound showing him how well my truck runs and ik jumped the mound hehe and then ik hit the sde of the mound and copped a savage to my stomach ouch lol reactor was laughing his ass of while i was winded
 
1 - 18 of 18 Posts
Top