Australian RC Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,343 Posts
Discussion Starter · #1 ·
hey ppl.. im proud to say.. my savage has arrived @ my door.. and im WRAPPED!



however..... im having a little problem starting the beast!..



this unit is not brand new.. so it has been broken in..

to start the car i put the glow plug ignitor in.. and the rotostart..

it started for like 3 seconds.. then no more.. so i tried again.. and it didnt start...





i think the savage is flooded!



ive undone the glow plug.. tested it.. works fine... and while glow
plug is off.. i disconnected the fuel line.. and tried the rotostart..
(so that it unfloods the engine).. with no more fuel being pumped in....



i did this for like 10 - 15 seconds.. spins nice and freely..

however... after i put the glow plug back in.. and try to start the
beast.. with the glow plug in.. the rotostart hardly does a rotation...
feels very tight.. so i took it out quickly.. didnt wanna damage
anything???..





what now???
 

·
Registered
Joined
·
405 Posts
I'm sure there is more helpful suggestions than this and I really have to fly but I'd say:

  1. <LI>Engine out of tune</LI>
    <LI>Rotostart battery low/flat?</LI>
    <LI>Engine is probably still flooded- turn savage on side and punch rotostart (with plug out) and you'll probably get a nice spray. When starting the Savage - don't prime the fuel TOO MUCH... I have - and it just makes life difficult. I find if I prime it to when you see it just kiss the carb in the fuel line - that's plenty!</LI>
    <LI>Have you tried opening the throttle a little? I start my savage always with the radio gear on - and I use my throttle trim and I have to adjust it up a bit to start the Savage and until it has warmed up a bit.</LI>
    <LI>If it feels tight and the rotostart batteries are good - it's deffinately flooded. Don't push it.
    </LI>


Hope I've helped a little...


Jerrah.
 

·
Registered
Joined
·
1,343 Posts
Discussion Starter · #3 ·
thanks jerrah..



ok.. when i thought it wasnt flooded.. i was wrong
.. on its side.. u get a LOT more
..



i did that.. but then i was playing with the roto-start.. and now its
flat
.. but it was STRONG as before.. as in.. the rotostart would
twist my hand.. so i took it off! LOL!..didnt wanna damage anything!..



cheers.. im gonna go to the LHS tommorow after school and get them to
sell me a charger for rotostart + humppack + get them to tune
everything!





cheers.. big help!
 

·
Registered
Joined
·
1,343 Posts
Discussion Starter · #4 ·
ALL GOOD.. i got it working.. ahha i did it inside.. and now my
house stinks!.. lol.. (for like 1 min MAX).. + its 11:58pm here.. so
loud!.. ahahha im loving it

time to sleep and get up early






AWSOME
 

·
Premium Member
Joined
·
2,880 Posts
Hey guys,


I just removed a heap of posts from this thread. Lets keep it on topic... there are other places to organise bashing events.


Thanks guys.


Chris
 
1 - 6 of 6 Posts
Top