Australian RC Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
283 Posts
Discussion Starter · #1 ·
Hi

I've just got myself a Futaba s9402 servo, but when I installed it as steering, whenever I turn the steering wheel, the throttle servo would kinda twitch a bit, a few times. I have not upgraded my stock radio system on my Nitro TC3 to a good FM system yet, so it is still running on 27MHz AM with the stock receiver and the stock throttle servo, the only thing I've changed is the steering servo.
This problem does not happen when I plug my stock steering servo back in. So it makes me wonder if my Futaba faulty? or is it the receiver? or because of some other factors?
Thanx guys
 

·
Registered
Joined
·
87 Posts
Sounds crazy, but it could be a receiver pack on the way out. My servos start to twitch when the charge is getting low - are you using a 4.8 or 6V pack? If you're only using 4 NiCD or NiMH, you may want to think about going for 5...
 

·
Registered
Joined
·
283 Posts
Discussion Starter · #3 ·
thats what I thought, since the high torque and high speed servos draws more power right? I'm only using 4 x 1.5v alkaline atm, my ofna 1400mAH 5 cell pack should be here tomorrow or the day after, so I will charge it up and test it again.


Apart from that, could there be anything else that's causing this?


When I turn the steering real fast, like left then right, it only twitches a bit, but If i turn it very slowly, the problems gets much worse, like the throttle would twitch non stop, until I stop.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top