Australian RC Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
371 Posts
Discussion Starter · #1 ·
I've narrowed my throttle problem down to the servo's. I can't seem to keep the throttle closed when in neutral. The space is about 60mm and when i brake it closes but not in neutral. How do i fix this problem?





thanks jordan
 

·
Premium Member
Joined
·
6,579 Posts
Adjust the trim on your throttle, or better still sit down and completely revise your throttle linkage. It takes a while to perfect it.


At neutral the carb should be at idle position - nothing more, nothing less.


When you apply full brake, the carb opening must not change.
 

·
Registered
Joined
·
99 Posts
I have my throttle set so it sits firmly shut in neutral, the spring is just compressing a bit - and the brakes are still loose as. That way it gives a little bit of slack in each direction, makes it easier to control in the air. Just have to make sure the servo travel is set right so you don't strip servo gears, or bend or break anything!
 

·
Registered
Joined
·
166 Posts
yeh i hav my trim set so central position on the TR and then set my
servo horn on the central position aswell so that if i need to set it
more on the brakes i set the trim on the TR but if i need a little more
throttle for those stubborn starts i adjust the trim to open the carb a
little.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top