Australian RC Forums banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
4,136 Posts
Discussion Starter · #1 ·
Gidday all,


I told a friend that I would put up a post regarding his brake problems.


I've told him you are all an intelligent buch, so please don't let me down.


Rob has just replaced the stock brake disk and hub with the Savage stainless kit - 2 disks.


Only problem now, is that the brake is so good, he ends up doing forward rolls when he applies the brakes.


I'm only a humble Terra Crusher owner and so have little experience with the Savage.


Any recommendations?


Cheers


Steve
 

·
Premium Member
Joined
·
6,579 Posts
Try put a longer piece of fuel tube or a spring onto the brake linkage.


You want to reduce the "grab" when the brakes first hit.
 
G

·
Did you install the brake disk on the invest direction?


Because some of the brake disk has channals, and if you put it on with other side, the brake pad will scrach the brake disk really hard.





Make sure your brake disk in on the right side, and may be you can make your brake pad thinner.


Hopes this information helps you.
 

·
Premium Member
Joined
·
4,136 Posts
Discussion Starter · #4 ·
Thanks guys,


It looks like we won't be running the trucks this weekend, as it's been a heatwave in Sydney today and the same is forecasted for tomorrow.


I'll try your suggestions and see how we go.


Cheers,


Steve
 

·
Registered
Joined
·
761 Posts
If he hassnt done the Throttle / BreakLinkage mod, then he should have a small black round thing on the end of the break rod on the front of the truck next to the throttle servo, tell him to loosen it by twisting it counter clockwise but adjust it while the truck is running so he can loosen it until its just right cause theres no use in doing it when the truck isnt running because it doesnt show anything
 
1 - 5 of 5 Posts
Top