Australian RC Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I only get around 2 weekends(around 4 hours of bashing) out of a glow plug, im running a force 15 and use OS #8 plugs, should they last longer than that ? i use 20% nitro.

Cheers.
 

·
Registered
Joined
·
36 Posts
Have you stripped down the engine recently after the first glow plug went?
When a glow plug dies the tiny bits of wire coil can fall into the engine and bounce around.
then when you put in a new glow plug it starts and runs fine, but the bits of remanent wire coil are still bouncing around and will destroy the new plug.

best to take the head and rear cover off to have a look.
Steve
 

·
Premium Member
Joined
·
9,488 Posts
Have a look at your Fuel settings also, if the engine is running lean, it will chew glo plugs like a fat kid on a bag of lollies
 

·
Registered
Joined
·
527 Posts
Probably unlikely that the plugs are breaking up but it can happen, thats normally cheap low quality plugs that do that though & the O.S plugs are a good high quality. If the plugs are just dieing then its most likely something to do with fuel mixture settings, also, on the smaller engine with lower nitro try a warmer plug like the O.S #7, its only slightly warmer but should help make the tuning easier.
As for the dead plugs, how do the elements look, are they warped & distorted at all, normally the main reason a plug dies is because the engine is to lean & sometimes the excessive heat can cause the plug element to warp, not always though.
 
1 - 4 of 4 Posts
Top