Savage XL - RF30/TX20 issue
Page 1 of 2 12 LastLast
Results 1 to 20 of 28
  1. #1
    R/C Newbie
    Join Date
    Apr 2014
    Posts
    30
    Rep Power
    0

    Savage XL - RF30/TX20 issue

    Hi all I'm new here, and have my first mind bender. I'm having trouble with my 2.4GHz stock HPI TX/RX unit. (TX20 and RF30) The problems goes like this...

    I turn on the transmitter then receiver. They fire up fine, and I can use the truck. After driving it around for 10 minutes, the failsafe kicks in. Well I'm assuming its the F/S. If I open the radio box the little red LED on the RX unit is flashing. If I turn the RX unit off and on, the problem persists. If I completely unplug the RX from the battery then reconnect, it usually works again for another 5 - 10 mins.

    So far I have changed the TX batteries, fully recharged the RX battery, repacked the wires nice and neat. I'm wondering if I will need to pull all the connections and rewire it from scratch.

    The RX hump pack is the original 1200mah pack, its running at 6V when I test it during the failure.

  2. Remove Advertisements
    AUSRC.COM
    Advertisements
     

  3. #2
    Senior Moderator
    towie964's Avatar
    Join Date
    Mar 2009
    Location
    Brisvegas AYE!!
    Posts
    9,488
    Rep Power
    10
    My first guess would be your Hump Pack is no longer storing a full charge....the voltage could be dropping away and causing the radio system to go into fail safe mode

    Try plugging in a 4 x AA battery holder with 4 fresh Alkaline AA batteries, if the problem goes away, the problem is solved




    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    Baja...Because Size Matters!

    Everybody is adding famous quotes to their sigs, so...My Mother to my Father on Disciplining me as a child....You hit him Noel, My Arm is getting tired.

  4. #3
    R/C Newbie
    Join Date
    Apr 2014
    Posts
    30
    Rep Power
    0
    Hrmmm bloody electrics. I just bought a new hump pack, will see how it goes. Thanks for the advice.

  5. Remove Advertisements
    AUSRC.COM
    Advertisements
     

  6. #4
    R/C Guru savage600's Avatar
    Join Date
    Aug 2008
    Location
    Nairne S.A.
    Posts
    603
    Rep Power
    12
    Hi Jords, I have a similar issue with my savage x 4.6ss and the problems it presents are what you are describing. I have cycled the hump pack a few times on the charger as I have no idea how old the pack is. I was able to run the truck for a full tank without the issue happening again.

    I am not using the HPI tx and rx, but a spektrum dx3r pro and a clone spektrum rx.

    How old is the hump pack you have? but I guess if you have a new one on the way then it doesn't matter and if it does come good then you have a spare.

    Cheers Dave.
    baja 5sct shorty, MCD RRv4 Full mod 29.5 OBR ( and lots of bling ) savage xs flux, savage x 4.6 ss, hpi firestorm flux, axial scx10, mcpx x3.

  7. #5
    Senior Moderator
    towie964's Avatar
    Join Date
    Mar 2009
    Location
    Brisvegas AYE!!
    Posts
    9,488
    Rep Power
    10
    I am not a fan of the stock Hpi radio sets in general, although the TF40 is not to bad....most times I do the same as Dave, I instal a Spektrum receiver and TX




    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    Baja...Because Size Matters!

    Everybody is adding famous quotes to their sigs, so...My Mother to my Father on Disciplining me as a child....You hit him Noel, My Arm is getting tired.

  8. #6
    R/C God snap off racing's Avatar
    Join Date
    Oct 2008
    Location
    Omicron Persei VIII
    Posts
    3,741
    Rep Power
    15
    I got a 2.4gig hpi radio set on a mini recon that glitches pretty bad.
    Seems it clashes with something in the lounge room.

  9. #7
    Senior Moderator
    towie964's Avatar
    Join Date
    Mar 2009
    Location
    Brisvegas AYE!!
    Posts
    9,488
    Rep Power
    10
    That should be a TF40 on the mini recon....try re-binding it, it sometimes improves them




    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    Baja...Because Size Matters!

    Everybody is adding famous quotes to their sigs, so...My Mother to my Father on Disciplining me as a child....You hit him Noel, My Arm is getting tired.

  10. #8
    R/C God snap off racing's Avatar
    Join Date
    Oct 2008
    Location
    Omicron Persei VIII
    Posts
    3,741
    Rep Power
    15
    I'll give that a crack at some stage Pete.

  11. #9
    R/C Newbie
    Join Date
    Apr 2014
    Posts
    30
    Rep Power
    0
    So if I were to buy a new tx/rx, is there anything under $100 that's worth buying? I'd the spektrum dx2 any good?

  12. #10
    R/C God Sonic's Avatar
    Join Date
    Jul 2004
    Location
    Australia - Melbourne
    Posts
    1,963
    Rep Power
    17
    Fly Sky FS GT3C 3channel 2.4GHZ around the $60.00
    Savage 3 speed Infinity 32R-Z- Savage Flux XL - Savage Flux - Savage XS - E-Revo BL- Traxxas Summit BL - TT ST1 BL - TT MT4 G3 - Kyosho Mad force LE - Wild Willy 2 - Tamiya CR01 - Smash Shark BL.

  13. #11
    Senior Moderator
    towie964's Avatar
    Join Date
    Mar 2009
    Location
    Brisvegas AYE!!
    Posts
    9,488
    Rep Power
    10
    Quote Originally Posted by Jords View Post
    So if I were to buy a new tx/rx, is there anything under $100 that's worth buying? I'd the spektrum dx2 any good?

    DX2 is a good radio, but 1 channel short IMO...I prefer to have the 3rd or even 4th channel spare in case it is needed...I have never had issues with the Spektrum Radios, although in the early days, there were people that reported range issues...Spektrum and Futaba would be the 2 most popular radios in the industry, followed by the Chinese made gear, many of which are fine for most applications.




    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    Baja...Because Size Matters!

    Everybody is adding famous quotes to their sigs, so...My Mother to my Father on Disciplining me as a child....You hit him Noel, My Arm is getting tired.

  14. #12
    R/C Guru savage600's Avatar
    Join Date
    Aug 2008
    Location
    Nairne S.A.
    Posts
    603
    Rep Power
    12
    Quote Originally Posted by Sonic View Post
    Fly Sky FS GT3C 3channel 2.4GHZ around the $60.00
    I have heard some decent things about the Fly Sky radio and that is what my baja had when I got it and another plus is that the receivers are not too dear.

    Cheers Dave.
    baja 5sct shorty, MCD RRv4 Full mod 29.5 OBR ( and lots of bling ) savage xs flux, savage x 4.6 ss, hpi firestorm flux, axial scx10, mcpx x3.

  15. #13
    R/C Guru savage600's Avatar
    Join Date
    Aug 2008
    Location
    Nairne S.A.
    Posts
    603
    Rep Power
    12
    http://www.largescaledownunder.com.a...ic,1322.0.html

    Hey Jords, above is a link to LSD and a thread about one of the Fly Sky radios, may be of interesting reading for ya.

    Cheers Dave.
    baja 5sct shorty, MCD RRv4 Full mod 29.5 OBR ( and lots of bling ) savage xs flux, savage x 4.6 ss, hpi firestorm flux, axial scx10, mcpx x3.

  16. #14
    R/C Apprentice rcnutbag's Avatar
    Join Date
    Feb 2014
    Location
    Canberra
    Posts
    104
    Rep Power
    6
    I also have the flysky gt3c and I think there great. I got mine from hobby warehouse for $56 bloody bargain

  17. #15
    R/C Newbie
    Join Date
    Apr 2014
    Posts
    30
    Rep Power
    0
    Well the new battery hasn't solved anything, put it in today and got 10-15 minutes run time out of it before the failsafe kicked in again. I'm at a loss to what it is, might just have to buy a new radio set.

  18. #16
    Senior Moderator
    towie964's Avatar
    Join Date
    Mar 2009
    Location
    Brisvegas AYE!!
    Posts
    9,488
    Rep Power
    10
    Dont go buying a radio just yet...

    The new battery will take about a dozen cycles before it reaches it's full potential and payload....each time over the next 10 to 15 charge cycles, the battery should take in a little more than the last charge cycle put in.

    On a side note, what servos are you running, some servos will draw a lot more current from the battery, this shortens the overall run time you will get from a charge




    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    Baja...Because Size Matters!

    Everybody is adding famous quotes to their sigs, so...My Mother to my Father on Disciplining me as a child....You hit him Noel, My Arm is getting tired.

  19. #17
    R/C Newbie
    Join Date
    Apr 2014
    Posts
    30
    Rep Power
    0
    Running bog stock servos.

    The failsafe thing doesn't seem battery related. I got 15 mins the first time, it cut in to failsafe after flipping the truck. If I disconnect the battery for 10 mins, I get another 10 to 15 mins out of it. I find it goes to failsafe when I stop the car or have a crash, it doesn't just cut out mid run. Every time it dies I just need to give it 10 mins to recover and it goes again. Bloody wierd.

    On another note I wound up pulling the whole engine apart today for a thorough clean after discovering the air filter had popped off after a bit of a cartwheel. I didn't realise for about 5 mins so she sucked a bit of dirt. Looks like I got away with it, no scratches on internals or broken bits.

  20. #18
    R/C Guru savage600's Avatar
    Join Date
    Aug 2008
    Location
    Nairne S.A.
    Posts
    603
    Rep Power
    12
    As Towie mentioned above about some servos using a lot of power etc and you mention that you have the bog stockies, have you had a look over the car if something is binding anywhere. If it is, this may cause things to heat up or use more power than you want. Do you have any pinched wires or the like on the car also? Just a thought.

    Cheers Dave.
    baja 5sct shorty, MCD RRv4 Full mod 29.5 OBR ( and lots of bling ) savage xs flux, savage x 4.6 ss, hpi firestorm flux, axial scx10, mcpx x3.

  21. #19
    R/C Newbie
    Join Date
    Apr 2014
    Posts
    30
    Rep Power
    0
    I took the switch out today and got about 3 hours of clean runtime. Methinks the switch is buggered. Had a great time, even though I chewed out the front diff and lost a wheel nut. Now have a standard M5 nut holding the wheel on and running RWD. I have a growing list of parts I need to order next week!

  22. #20
    R/C Guru savage600's Avatar
    Join Date
    Aug 2008
    Location
    Nairne S.A.
    Posts
    603
    Rep Power
    12
    Sounds like you have it sorted mate, nice work.

    Cheers Dave.
    baja 5sct shorty, MCD RRv4 Full mod 29.5 OBR ( and lots of bling ) savage xs flux, savage x 4.6 ss, hpi firestorm flux, axial scx10, mcpx x3.

Page 1 of 2 12 LastLast

Similar Threads

  1. Savage Throttle return spring issue
    By SavageHandle in forum Monster Truck - Nitro 1/8 Scale
    Replies: 11
    Last Post: 07-11-2010, 03:09 PM
  2. Another issue
    By d5ive in forum Truggies - Nitro
    Replies: 33
    Last Post: 28-01-2010, 09:30 PM
  3. Another Savage XL issue.. driving me nuts...
    By MMarano in forum Monster Truck - Nitro 1/8 Scale
    Replies: 4
    Last Post: 26-06-2009, 03:33 PM
  4. HELP! Savage XL issue its driving me crazy..
    By MMarano in forum Monster Truck - Nitro 1/8 Scale
    Replies: 11
    Last Post: 16-06-2009, 05:32 PM
  5. Savage 2nd gear issue
    By cooks in forum Monster Truck - Nitro 1/8 Scale
    Replies: 10
    Last Post: 09-07-2008, 02:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •